使用两个路由器在 vlan 之间进行路由

网络工程 思科 路由 转变 局域网
2022-02-01 23:22:29

我正在做一个简单的练习来了解如何在 vlan 之间进行路由。我有这个设置,顶部有一个路由器和三个 vlan。

Packet Tracer 7 可视化

我已经创建了 vlan 并为 Router1 中的每个 vlan 添加了封装,并相应地为网关分配了 IP。

Router1 具有以下配置:

Current configuration : 865 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/0.2
 no ip address
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 encapsulation dot1Q 2
 ip address 192.168.1.254 255.255.255.0
!
interface FastEthernet0/1.2
 encapsulation dot1Q 3
 ip address 192.168.2.254 255.255.255.0
!
interface FastEthernet0/1.3
 encapsulation dot1Q 4
 ip address 192.168.3.254 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Switch0 配置了以下 vlan:

Current configuration : 1091 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

Switch1 配置了以下 vlan:

Current configuration : 1288 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 description connects to PC1
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
 description connects to Switch0
 switchport mode trunk
!
interface FastEthernet0/23
 description connects to Switch2
 switchport mode trunk
!
interface FastEthernet0/24
 description connects to router1
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

Switch2 配置了以下 vlan:

Current configuration : 1114 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 4
 switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

PC1 有以下配置:

IP: 192.168.2.1
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.2.254

PC2有以下配置:

IP: 192.168.3.1
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.3.254

无线路由器有以下配置:

Default Gateway: 192.168.1.254
IP Address: 192.168.1.1
Subnet Mask: 255.255.255.0

笔记本电脑正在从无线路由器获取 dhcp。

每个人都应该和任何人交谈。两台 PC 相互通信,笔记本电脑可以连接到 PC。但我不知道需要什么才能使 PC 与笔记本电脑通信或成功 ping 无线路由器。

这是我的数据包跟踪器 7 文件: executive_pkt

2个回答

我认为您的问题源于无线路由器,不幸的是,它是一种消费级设备,因此在这里显然是题外话。很可能,它配置了防火墙,在 WAN 接口上丢弃 ICMP,并且它不会响应 ping。如果要 ping,则需要禁用它。如果无线路由器正在执行 NAT,那么您将无法启动从路由器外部到内部的流量。如果要 ping 笔记本电脑,则应禁用 NAT。

此外,您将需要两个路由器中的路由,以便它们知道如何到达另一路由器另一侧的网络。路由器通过三种方式学习路由:

  • 直连网络
  • 静态配置的路由
  • 来自路由协议的动态

Router1 需要知道它应该转到无线路由器,以便访问无线路由器另一端的网络。你没有给出使用你在无线路由器另一端使用的网络,所以我将10.1.1.0/24作为一个例子。在 Router1 上,您可以使用静态路由:

ip route 10.1.1.0 255.255.255.0 192.168.1.1

在无线路由器上,您需要配置到192.168.2.0/24192.168.3.0/24 through192.168.1.254 . The wireless router already knows how to reach the192.168.1.0/24` 网络的路由,因为它直接连接到它。

对于您的其他配置,您应该进行一些调整以遵循最佳实践。

在 Router1 上,您应该设置主机名以匹配图表。如果希望通过 telnet 连接到路由器,您还需要在 VTY 线路上输入密码。

hostname Router1
!
line vty 0 15
 password MyRouter1Password
 login
!

在 Switch0 上,您应该为连接到 Switch1 的接口配置一个中继接口。在接口上使用描述,包括连接到无线路由器的接口。此外,如果您希望通过 telnet 连接到交换机,您还需要在 VTY 线路上输入密码。

hostname Switch0
!
interface FastEthernet0/23
 description Connection to Wireless Router F0/0
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/24
 description Connection to Switch1 F0/22
 switchport mode trunk
!
line vty 0 15
 password MySwitch0Password
 login
!

在 Switch1 上,使用接口描述。此外,如果您希望通过 telnet 连接到交换机,您还需要在 VTY 线路上输入密码。

hostname Switch1
!
interface FastEthernet0/22
 description Connection to Switch0 F0/24
 switchport mode trunk
!
interface FastEthernet0/23
 description Connection to Switch2 F0/24
 switchport mode trunk
!
interface FastEthernet0/24
 description Connection to Router1 F0/1
 switchport mode trunk
!
line vty 0 15
 password MySwitch1Password
 login
!

在 Switch2 上,使用接口描述。此外,如果您希望通过 telnet 连接到交换机,您还需要在 VTY 线路上输入密码。

hostname Switch2
!
interface FastEthernet0/24
 description Connection to Switch1 F0/23
 switchport mode trunk
!
line vty 0 15
 password MySwitch2Password
 login
!

由于在外围路由器中启用了 VLAN 间路由。默认情况下,PC 和笔记本电脑应该相互 ping 通。如果不是 pi g 意味着检查

  1. 在外围路由器上配置的任何访问列表。如果根据要求配置了访问列表。

  2. 检查窗口操作系统防火墙状态。如果是 Windows 防火墙或任何其他操作系统检查操作系统级别的防火墙状态。应允许 Ping 入站和出站。