如何 - 在 Nexus 中使用正则表达式来搜索这个 | 或者那个?

网络工程 思科 cisco-nx-os cisco-nexus-7k
2021-07-22 20:00:08

如此恶化 - 我找不到关于如何使用 Nexus regex 命令的好的文档。

所以,如果我的界面是这样的:

interface Vlan224
  description MANAGEMENT
  no shutdown
  ip flow monitor netflow-monitor input  
  no ip redirects
  ip address 10.214.224.2/24
  ip ospf passive-interface
  ip router ospf 1 area 0.0.0.3
  ip pim sparse-mode
  hsrp version 2
  hsrp 224 
  preempt 
  priority 120
  ip 10.214.224.1 

我想运行类似于:

show run | inc (interface Vlan)|(ip address)

并且输出看起来类似于(如果这是在 IOS 上):

interface Vlan10
ip address 10.1.10.1 255.255.255.0
interface Vlan 11
ip address 10.1.11.1 255.255.255.0
etc.
4个回答

你可以做一个show run | egrep interface.Vlan|ip.address. 它确实获取了更多信息,但应该提供与您在 IOS 中看到的类似的输出。我认为 grep 也可以工作,但我使用了 egrep 并得到了正确的输出。

如果您只是在寻找 Vlan 接口的 IP 地址,更好的方法可能是: show ip int br | grep -i vlan

注意:show ip int br在 NXOS 中只显示第 3 层接口。要查看所有接口的状态,请使用show int br

更新:

对于 NXOS 4.0(2) 及更早版本: show run | grep -i face\ vlan|ip\ address

4.0(3) 及更高版本: show run | grep ignore-case face\ vlan|ip\ address

也是\如何用正则表达式来逃避空间。NXOS 正则表达式链接:http : //www.cisco.com/en/US/docs/switches/datacenter/sw/4_0/nx-os/fundamentals/configuration/guide2/fun_3about_cli.html#wp1237003

涉及单引号的替代语法。

# show run | inc 'interface Vlan|ip address'

在 NX-OS 中,参数解析的工作方式很像 bash。

我看到文档说这应该有效:

show run | inc interface_Vlan|ip_address

虽然在 4k 刀片式交换机上对我来说似乎并不适用。我成功了

sh run | inc interface.Vlan|ip.address