假设您拥有正确的 IOS 和功能集(已加载 IOS >=15.0(1)M7 & Adv IP Services 许可证),最简单的方法是将每个互联网链接和 Vlan 放在不同的 VRF(这是一个VRF-精简配置)。假设您要使用:
- Vlan10 的 Ethernet1/0 上行链路
- 用于 Vlan20 的 Ethernet2/0 上行链路
配置看起来类似于这个......
ip vrf Inet_Vlan10
rd 65535:10
route-target 65535:10
!
ip vrf Inet_Vlan20
rd 65535:20
route-target 65535:20
!
interface Ethernet1/0
ip vrf forwarding Inet_Vlan10
ip address 192.0.2.2 255.255.255.252
! insert nat, if required
interface Ethernet2/0
ip vrf forwarding Inet_Vlan20
ip address 192.0.2.6 255.255.255.252
! insert nat, if required
interface Vlan10
! This assumes you're using the onboard switch in a C800 series
ip vrf forwarding Inet_Vlan10
ip address 10.0.1.254 255.255.255.0
! insert nat, if required
interface Vlan20
! This assumes you're using the onboard switch in a C800 series
ip vrf forwarding Inet_Vlan20
ip address 10.0.2.254 255.255.255.0
! insert nat, if required
! Simple example of routing Vlan10 out Ethernet1/0
ip route vrf Inet_Vlan10 0.0.0.0 0.0.0.0 <ip_addr_in_192.0.2.0/30>
! Simple example of routing Vlan20 out Ethernet2/0
ip route vrf Inet_Vlan20 0.0.0.0 0.0.0.0 <ip_addr_in_192.0.2.4/30>
VRF 为每个 VRF 指定不同的转发表;因此,您可以完全按照您在问题中的描述,为每个 Vlan 指定一个 Internet 访问提供商。