概括
这是在正确的轨道上吗?
是的......与评论中的链接非常相似......正如你所提到的,你只需要做两件事......
- 在全局接口上配置 NAT 过载
- 在 VRF 中为速度测试服务器放置一条静态路由...
细节
假设您的速度测试服务器在 172.16.10.5... 并且您正在尝试从 VRF01 中的 CE 交换机 ping 它。
To Speed Test Server
(172.16.10.5, NH 172.16.1.1)
<-------
Fa0/0 (global table) +-----+ Fa1/0 (VRF01) Fa0/17 +-----+
172.16.1.200 | | 192.0.2.1/24 192.0.2.100/24 | |
---------------------| PE1 |----------------------------------| CE1 |
| | | |
+-----+ +-----+
PE1的配置
!!! PE1 Config
!
hostname PE1
!
ip vrf VRF01
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface FastEthernet0/0
description global table interface
ip address 172.16.1.200 255.255.255.0
no ip proxy-arp
ip nat outside
ip virtual-reassembly
!
!
interface FastEthernet1/0
ip vrf forwarding VRF01
ip address 192.0.2.1 255.255.255.0
no ip proxy-arp
ip nat inside
ip virtual-reassembly
!
ip route vrf VRF01 172.16.10.5 255.255.255.255 172.16.1.1 global
!
!! Insert other PE1 global routing configs
CE1的配置
!!! CE1 Config
!
hostname CE1
!
interface FastEthernet0/17
switchport access vlan 11
switchport mode access
switchport nonegotiate
!
!
interface Vlan11
ip address 192.0.2.100 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.0.2.1
Ping 证明...
CE1#ping 172.16.10.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
CE1#
NAT 条目...
PE1#sh ip nat trans
Pro Inside global Inside local Outside local Outside global
icmp 172.16.1.200:3 192.0.2.100:3 172.16.10.5:3 172.16.10.5:3
PE1#